Heroes Premium 10% OFF BEST RPG PLUGIN EVER 1.9.25 V3 [提交至百度][查看百度是否已收录此帖]

4209 0
2023-1-29 09:44:33
显示全部楼层
生活圈制作
Heroes Premium  10% OFF BEST RPG PLUGIN EVER 1.9.25 V3   

下载地址
提取码:qi6t
20
您未购买

人民币


本机 Minecraft 版本:1.16 经过测试的 Minecraft 版本:
  • 1.8
  • 1.9
  • 1.10
  • 1.11
  • 1.12
  • 1.13
  • 1.14
  • 1.15
  • 1.16
  • 1.17
  • 1.18
  • 1.19
贡献者:Kainzo、Mung3r、Soren_Endor、Sleaker、0xnaomi、KASHIKE、Ampayne2、Tommo
Minecraft RPG 插件功能 Class/Professions with Levels Heroes Skills & Permission Skills Skill Binding Inventory Restrictions Alternative Health/Damage System Party EXP Sharing & Party Loot Rolling 改进的技能框架 法力和耐力系统 改进的帮助和命令 统计/记分板系统 冷却动作栏可切换的 暴民健康栏 属性与 GUI 增强的目标系统 香草制作限制 奖金 EXP 许可节点 改进的派对系统与分裂 EXP 收益























技能图标 + 热栏与 类更改的魔法命令结合使用 抽象类进程 屏蔽健康系统 SQL 或 YML 存储 PlaceholderAPI 支持 语言支持技能 神话技能集成! ================ WIKI ================高级技能包✫血与火✫✫符文与愤怒✫✫歌曲与宁静✫ ✫狡猾和浅黄色 ✫ ✫神秘和可怕✫ ✫荣誉和自然✫ ✫死亡和神圣✫




















✫潜行和飞镖 ✫
✫魔法技能(非 1.15+ 兼容) ✫

附加组件:
英雄技能快捷栏


需要:
Java 11 + VAULT + Spigot(Bukkit 不会运行)
技能取决于 > EffectLib
推荐权限 > zPermissions

EXTRA:
1.11的 公共技能包| 1.10~

计划中的功能
适当的公民支持
英雄属性自定义项目支持
脚本技能

API| Java 文档在这里| 最好用PaperSpigot| 默认配置
想免费试用吗?在此处下载 1.16 及以下版本

介绍为多人服务器
Herocraft
创建的第一个 Minecraft 角色扮演插件!Heroes 是一个动态、灵活且高度可配置的职业、技能和经验系统。Heroes 本身就是您的玩家角色扮演游戏体验、引以为豪的职业、多层次和高级技能的中心。除了课程之外,Heroes 还通过我们完善的技能系统和我们的武器 + 盔甲限制为您的玩家提供全新的 PvP 和 PvE 风格。你的法师将不再能够使用钻石剑,你的流氓将不再穿着沉重的钻石外衣偷偷摸摸,最重要的是,你现在可以投掷火球并击晕你的目标。这个当中最好的部分?英雄的设置方式由您选择,不需要某个技能,没关系,您可以删除该技能并完成它!

我能用它做什么?
使用 Heroes,您几乎可以在 RPG 服务器上做任何您想做的事情。主要特点是我们可定制的分层课程系统,当与我们的技能和许可技能相关联时,它会为服务器所有者提供尽可能多的服务。您的英雄对于您的服务器可能是完全独一无二的,这可能是玩家在您的服务器上玩而不是其他服务器的原因。我们的技能系统也是如此,它对于任何其他 RPG 插件都是独一无二的。其他插件将“技能”称为您升级的方法,但英雄并非如此。技能是您可以执行的能力,这对您的班级来说是独一无二的。我们最喜欢的一些技能是 Fireball、Jump 和 Port。这些就是英雄的独特之处。

功能深入
  • 班级
    • 创建您自己的独特类或使用默认值!
    • 权限节点设置默认用户可以获得哪些类
    • 自定义类名
    • '父母| 孩子的可选关系,(例如 HEALER -> CLERIC)
    • 可配置的库存限制
    • 双重职业!(主要,次要或两者兼而有之,多职业)
  • 属性
    • 力量 - 增加近战武器的伤害,以及基于物理的能力的伤害
    • 体质 - 增加你的最大生命值,并且对基于魔法的伤害提供轻微的抵抗力
    • 耐力 - 增加你的基础耐力再生,同时增加你的最大装备重量。一次穿好几件盔甲需要很高的装备重量值
    • 敏捷 - 增加基于弹丸的武器的伤害,以及你的基本移动速度。此属性也可能会增加某些能力的有效性
    • 智力 - 增加你的最大法力值,同时增加基于魔法的能力造成的伤害
    • 智慧 - 增加你的基础法力恢复,也增加治疗能力的效果
    • 魅力 - 增加歌曲的效力,并增加某些禁用能力的持续时间和有效性
  • 惊人的技能
    • 超过 100 种基础技能!使用高级包获得更多!
    • 可用于 /bind 到你的物品或 /skill
    • 与 Magic hotbar 魔杖系统或 MacroMod 客户端配对!
    • 适用于属性、法力、健康和其他试剂!
  • 允许的技能
    • 群英会基础平台技能
    • 所有允许的技能都以 /skill <skillname> 开头
    • 允许开发人员添加自己的代码以获得新技能
    • 可通过 skills.yml 调整或在课程设置中覆盖
  • 权限技巧
    • 基于权限节点系统,能够设置学习某些权限节点所需的级别以具有高度可配置的系统。
    • 不使用 /skill 前缀 - 权限技能不链接到它们只是授予玩家权限的任何命令
  • 使用技能
    • 能够“/绑定 <skillname>”到一个项目以右键单击并使用该技能
    • 再次使用'/bind'清除绑定并移除右键单击能力
    • 目前仅适用于许可技能
    • 通过“/mskills”与 Magic 插件集成
    • /hero skill version <skill> (或 /hero admin skill version <skill>)
  • 热压技能使用
    • 绑定系统的替代品
    • 让玩家使用配置了 Magic 插件的快捷栏
    • 将“skills_use_heroes: true”添加到您的Magic配置中!
  • 库存限制
  • 关卡
    • /level - 显示有关级别的信息 - 带有一个漂亮的界面,可以显示还剩多少才能获得下一级别。
    • 设置精通水平——一旦达到,用户可以切换到不同的班级,并将他们的水平/技能保存在精通班级中。
    • 可配置的 exp 曲线,使较低的级别更容易通过,而更高的级别更难通过
    • 每个级别的可选健康增益
    • 当前等级的可配置经验损失(每次死亡 0.10 = 10%)
  • 经验来源
    • SKILL - 使用技能的 exp
    • CRAFTING - 用于制作物品的 exp
    • MINING - 用于挖掘块的 exp
    • KILLING - exp 杀死怪物
    • LOGGING - 用于顶起木材的 exp
    • PVP - exp for PVP
    • QUESTING - 在 API 中用于任务插件
    • EXTERNAL - 用于普通 API
  • 健康/伤害
    • 设定环境破坏
    • 设置怪物健康/伤害
    • 允许床上治疗玩家在床上恢复健康!
    • 设置玩家健康(与心脏比率一起使用)
    • 设置广泛的项目损坏或覆盖其类文件中的单个类!
  • 法力
    • /mana - 显示当前的法力值 - 上限为 100%。
    • 每个班级可配置的魔法恢复率
    • 再生之间的时间是服务器范围的
  • 耐力
    • /stamina - 法力的替代系统
    • 再生速度比法力快
    • 可以切换香草饥饿系统!
  • 屏蔽
    • /shields - 替代的健康系统
    • 随着时间慢慢恢复
    • 类似于暗黑破坏神2风格的“魔法护盾”
  • 派对
    • 经验-分享-开/关
    • PVP - 开/关
    • 每个额外的党员奖励 Exp
    • 团体技能
    • 易挥发的


PAPI Papi 扩展 Jar 代码(文本)的技能展示










占位符
: prefix = %heroes_PLACEHOLDERNAME% %heroes_party_leader% %heroes_party_size% %heroes_stamina% %heroes_maxstasmina% %heroes_mana% %heroes_maxmana% %heroes_class% %heroes_class2% %heroes_class_level% %heroes_class2_expolevel% %her % %heroes_class2_exp% %heroes_class_maxexp% %heroes_class2_maxexp% %heroes_class_exp_percent% %heroes_class2_exp_percent% %heroes_skill_level_% %heroes_class_description% %heroes_class2_description% %heroes_class_tier%























%heroes_class2_tier%
%heroes_mastered%
%heroes_ismastered_%
%heroes_class_ismastered%
%heroes_class2_ismastered%
%heroes_class_maxlevel%
%heroes_class2_maxlevel%
剧透:经验
剧透:命令
剧透:权限剧透:支持英雄的
秘密插件

剧透:神话般的技能

剧透:杂项更改

英雄 API

  • 开发人员的重要更新
    我们终于更新了英雄的公共存储库!当前版本包括最新的 API 更改,与可用的 Heroes 免费版本相同。您可以这样设置 Maven 依赖项。
    <repository>
    <id>heroes-repo</id>
    <url> https://nexus.hc.to/content/repositories/pub_releases/ </url>
    </repository>

    <dependency>
    <groupId>com.herocraftonline。 heroes</groupId>
    <artifactId>Heroes</artifactId>
    <version>1.9.19-RELEASE</version>
    <scope>provided</scope>
    </dependency>
    点击展开...
    [url=]点击展开...[/url]



常见问题解答/未经测试/可能有问题

问:
英雄与公民合作吗?
A: Sorta.- Citizens -(作为 playerObjects 加载的 NPC 会导致一些冲突 - 联系 Citizen 以获得可能的修复)完全支持需要对 Heroes Framework 进行重大重写,以了解我们如何加载/保存类。避免在您的服务器上使用名为玩家的公民。

问:
我可以在 Heroes Premium 中使用 /reload 或 reload 插件吗?
A: "/reload" 会导致类管理器不稳定。不要使用/重新加载。Spigot 建议永远不要使用它。

问:您使用或推荐哪些权限系统?
答:我们推荐使用LuckPermszPerms. GM 和 PEX 许可系统未经测试/不受支持,YMMV。

问:我可以在 Heroes 中使用其他 RPG 系统(如 Mcmmo)吗?
答:大多数插件都会加载并且不会导致错误,由于两者都是“RPG”插件,因此可能存在一些哲学上的重叠。

问: 1.7 和 1.8 版本是否适用于 Heroes Premium
A: 1.7 和 1.8 可能有一些问题。除非针对这些版本进行编译,否则更高级的技能可能无法正常运行。1.8.8 是唯一受支持的 1.8 版本。

问:是否支持 Bukkit?
答:不支持 Craftbukkit。您应该使用 Spigot 或 PaperSpigot。

Q:英雄有语言文件吗?你能翻译一下吗
A:我们没有完整的语言文件,但是您可以自定义和更改描述的部分。请暂时使用MessageFilter 。

Q:我可以本地化技能描述吗?
答:是的。您可以通过编辑 Description 部分在 skills.yml 中执行此操作。

Q:我可以关闭体力并使用食物系统吗?
答:是的。您可以通过编辑相应的部分在 config.yml 中执行此操作。


有问题/疑问?
条款
  • 通过购买此资源,您将获得在您拥有、管理或工作的服务器上使用此插件的权利,只要您接触服务器的实际 Minecraft 方面并且不违反以下条件.
  • 通过购买此资源,只有您可以在项目期间获得支持。
  • 您不得以任何形式将此插件分发给未获得使用该插件的权利的任何人,例如通过从该资源页面购买该插件。
  • 已经获得资源后,您无法退款。它应该按照描述工作,如果您有问题,请联系我们,我们将尽最大努力解决这些问题!打开拒付将立即永久撤销您的访问权限。
  • 只要您遵守前面的条款,您就可以修改这个插件。
  • 作者可以随时撤销授予您的所有权利,尤其是在违反条款的情况下。
  • 下载即表示您接受先前的条款,并且该资源的分发没有作者的任何(甚至是暗示的)保证或责任。
不要将 BUG 报告直接留在问题跟踪器的

评级中 =====================================
最新的 LEGACY 1.12 版本
需要 Vault 1.6 或较低
的技能需要 6.2 的EffectLib
===============================


请将您的启动日志和任何错误粘贴到 paste2.org相关的!包括服务器/英雄版本。

新评论
--- Spigot 是为http://herocraftonline.com > ( play.hc.to )



创建的必需 Minecraft RPG 插件 仍然不相信吗?>>>在此处查看旧版(免费)! &#9829; 享受?给我写一篇 ☆☆☆☆☆ 评论!超级简单!&#9829;



手机扫码浏览