Heroes Premium 10% OFF BEST RPG PLUGIN EVER 1.9.17 [提交至百度][查看百度是否已收录此帖]

4368 0
2022-10-21 09:36:28
显示全部楼层
生活圈制作
Heroes Premium  10% OFF BEST RPG PLUGIN EVER 1.9.17



Heroes Premium  10% OFF BEST RPG 插件 1.9.17

下载地址
提取码:5y7q
20
您未购买

人民币


您还应该查看:

支持者 - &#9876; Heroes Premium &#9876; 所有技能旧版 (< 1.13) 测试的 Minecraft 版本:1.8 1.9 1.10 1.11 1.12 1.13 贡献者:Kainzo、Mung3r、Soren_Endor、Sleaker、0xnaomi、KASHIKE、Ampayne2 Minecraft RPG 插件功能类/具有级别英雄技能和权限的职业...
blackspigot.com



支持者 - 英雄高级技能包 - 血与火(25+ 技能)测试的 Minecraft 版本:1.9 1.10 1.11 1.12 贡献者:Kainzo、Mung3r、Soren、Delf、0xnaomi Minecraft RPG 的英雄技能!需要 Heroes Premium 和 EffectLib!说明:只需解压缩技能并将它们放入您的...
blackspigot.com



本机 Minecraft 版本: 1.16
测试的 Minecraft 版本: 1.8 / 1.9 / 1.10 / 1.11 / 1.12 / 1.13 / 1.14 / 1.15 / 1.16 / 1.17 / 1.18

Minecraft RPG 插件






特征
等级/职业
英雄 技能和许可技能
技能绑定
库存限制
替代健康/伤害系统
派对经验分享和派对战利品滚动
改进的技能框架
法力和耐力系统
改进的帮助和命令
统计/记分牌系统
冷却动作栏可切换的
暴民健康
带有 GUI 的条形属性
增强的目标系统
香草制作限制
奖励 EXP 权限节点
改进的带有拆分 EXP 的派对系统 与职业变化时的魔法 命令
结合时获得技能图标 + 热条

Abstracted Class Progression
Shielding Health System
SQL 或 YML Storage
PlaceholderAPI 支持
技能语言支持

=================
WIKI
===============
高级技能包
&#10027;血与火 &#10027;
&#10027;符文与狂暴 &#10027;
&#10027;歌声与宁静 &#10027;
&#10027;狡猾与 增益 &#10027;
&#10027;奥术与可怕 &#10027;
&#10027;荣誉与自然 &#10027;
&#10027;死亡与神圣 &#10027;
&#10027;潜行与飞镖 &#10027;
&#10027;魔法技能(非 1.15+ COMPAT ) &#10027;


插件:
英雄技能快捷栏要求



Java 11 + VAULT + Spigot(Bukkit 不会运行)
技能取决于 > EffectLib
推荐权限 > zPermissions


EXTRA:
1.11的 公共技能包| 1.10~


计划功能

适当的公民支持
英雄属性自定义项目支持
脚本技能

API| Java 文档在这里| 最好的PaperSpigot| 默认配置
免费公共构建:1.5.5.7 (仅限 MC 1.8)


为多人服务器Herocraft 创建的第一个 Minecraft 角色扮演插件!Heroes 是一个动态、灵活和高度可配置的职业、技能和经验系统。英雄本身就是玩家 RPG 体验的中心,拥有职业、多层次和高级技能。除了职业之外,《英雄》还通过我们完善的技能系统和我们的武器 + 护甲限制为您的玩家提供全新的 PvP 和 PvE 风格。你的法师将不再有使用钻石剑的能力,你的盗贼将不再穿着沉重的钻石外衣偷偷摸摸,最重要的是,你现在可以投掷火球并击晕你的目标。这个当中最好的部分?你的英雄如何设置是你的选择,不想要某个技能,没关系,你可以删除技能并完成它!

我能用它做什么?
使用 Heroes,您几乎可以在 RPG 服务器上做任何您想做的事情。主要特点是我们可定制的分层类系统,当与我们的技能和权限技能相结合时,它可以为服务器所有者提供尽可能多的服务。您的英雄可能对您的服务器来说是完全独一无二的,这可能是玩家玩您的服务器而不是其他服务器的原因。我们的技能系统也是如此,它是其他任何 RPG 插件所独有的。其他插件将“技能”称为您升级的方法,Heroes 并非如此。技能是你可以发挥的能力,是你的班级独有的。我们最喜欢的一些技能是火球、跳跃和港口。这些是使英雄与众不同的原因。

功能深入

  • 课程
    • 创建您自己独特的类或使用默认值!
    • 权限节点设置默认用户可以获得哪些类
    • 自定义类名
    • '家长 | 孩子的可选关系,(例如 HEALER -> CLERIC)
    • 可配置的库存限制
    • 双重分类!(主要、次要或两者兼有,多分类)
  • 属性
    • 力量 - 增加近战武器的伤害,以及基于物理能力的伤害
    • 体质 - 增加你的最大生命值,并提供对魔法伤害的轻微抵抗
    • 耐力 - 增加你的基础耐力再生,也增加你的最大装备重量。一次穿戴多件盔甲需要较高的装备重量值
    • 敏捷——增加基于射弹的武器的伤害,以及你的基本移动速度。某些技能的效果也可以通过这个属性增加
    • 智力 - 增加你的最大法力值,并增加魔法技能造成的伤害
    • 智慧 - 增加你的基础法力恢复,并增加基于治疗的能力的效果
    • 魅力 - 增加歌曲的效力,并增加某些禁用能力的持续时间和效果
  • 惊人的技能
    • 超过 100 种基础技能!使用高级包获得更多!
    • 可用于 /bind 到你的物品或 /skill
    • 与 Magic hotbar wand system 或 MacroMod 客户端配对!
    • 与属性、法力、健康和其他试剂一起使用!
  • 允许的技能
    • 英雄基础平台技能
    • 所有允许的技能都以 /skill <skillname> 开头
    • 允许开发人员添加自己的代码以获取新技能
    • 可通过技能.yml 调整或在类设置中覆盖
  • 许可技巧
    • 基于权限节点系统,能够设置学习某些权限节点所需的级别以拥有高度可配置的系统。
    • 不使用 /skill 前缀 - 权限技能不与任何命令相关联,它们只是授予玩家权限
  • 使用技能
    • 能够“/绑定 <skillname>”到一个项目以右键单击并使用该技能
    • 再次使用 '/bind' 清除绑定并移除右键单击能力
    • 目前仅适用于Permitted-Skills
    • 通过“/mskills”与 Magic 插件集成
    • /hero 技能版本 <skill>(或 /hero 管理员技能版本 <skill>)
  • 热吧技能使用
    • 绑定系统的替代方案
    • 让玩家使用配置了 Magic 插件的热栏
    • 将“skills_use_heroes: true”添加到您的魔法配置中!
  • 库存限制
  • 级别
    • /level - 显示有关级别的信息 - 带有一个漂亮的界面,可以向您显示获得下一个级别还剩多少。
    • 设置精通等级——一旦达到,用户可以切换到不同的班级,并将他们的等级/技能保存在所掌握的班级中。
    • exp的可配置曲线使较低的级别更容易,而较高的级别更难通过
    • 每级可选的健康增益
    • 按当前级别可配置的 exp 损失(0.10 = 10% 每次死亡)
  • 经验来源
    • SKILL - 使用技能的exp
    • CRAFTING - 用于制作物品的 exp
    • MINING - 开采区块的 exp
    • KILLING - 杀死怪物的 exp
    • LOGGING - 用于顶升木材的 exp
    • PVP - PVP的exp
    • QUESTING - 在 API 中用于 quest 插件
    • EXTERNAL - 在普通 API 中使用
  • 健康/伤害
    • 设置环境破坏
    • 设置怪物健康/伤害
    • 让玩家在床上恢复健康!
    • 设置玩家健康(适用于心率)
    • 设置广泛的项目损坏或覆盖其类文件中的单个类!
  • 法力
    • /mana - 显示当前的魔法值 - 上限为 100%。
    • 每个职业可配置的法力回复率
    • regen 之间的时间是服务器范围的
  • 耐力
    • /stamina - 法力的替代系统
    • 比法力恢复更快
    • 可以切换香草饥饿系统!
  • 屏蔽
    • /shields - 替代前健康系统
    • 随着时间的推移缓慢恢复
    • 类似于暗黑破坏神2风格的“魔法护盾”
  • 派对
    • 体验 - 分享 - 开/关
    • PVP - 开/关
    • 每个额外党员的奖励经验
    • 团体技能
    • 易挥发的



技能展示



















PAPI 的占位符 PAPI
扩展 Jar


PAPI 的占位符


代码:
prefix = %heroes_PLACEHOLDERNAME%%heroes_party_leader%%heroes_party_size%%heroes_stamina%%heroes_maxstasmina%%heroes_mana%%heroes_maxmana%%heroes_class%%heroes_class2%%heroes_class_level%%heroes_class2_level%%heroes_class_exp%%heroes_class2_exp%%heroes_class_maxexp%%heroes_class2_maxexp%%heroes_class_exp_percent%%heroes_class2_exp_percent%%heroes_skill_level_%%heroes_class_description%%heroes_class2_description%%heroes_class_tier%%heroes_class2_tier%%heroes_mastered%%heroes_ismastered_%%heroes_class_ismastered%%heroes_class2_ismastered%%heroes_class_maxlevel%%heroes_class2_maxlevel%




























































































支持英雄的插件
英雄 API
常见问题解答 / 未经测试 / 可能有问题

问:
Heroes 是否适用于 Citizens?
A: Sorta.- Citizens - (作为 playerObjects 加载的 NPC 会导致一些冲突 - 请联系 Citizen 以获得可能的修复)全面支持需要对我们如何加载/保存类的英雄框架进行重大重写。避免在您的服务器上使用被命名为玩家的公民。

问:
我可以在 Heroes Premium 中使用 /reload 或 reload 插件吗?
A: “/reload”会导致类管理器不稳定。不要使用 /reload。Spigot 建议永远不要使用它。

问:您使用或推荐哪些权限系统?
答:我们建议使用LuckPermszPerms. GM & PEX 权限系统未经测试/不受支持,YMMV。

问:我可以在 Heroes 中使用其他 RPG 系统(如 Mcmmo)吗?
答:大多数插件都会加载并且不会导致错误,由于两者都是“RPG”插件,可能存在一些哲学上的重叠。

问: 1.7 和 1.8 版本是否适用于 Heroes Premium
答: 1.7 和 1.8 可能存在一些问题。除非针对这些版本进行编译,否则更高级的技能可能无法正常运行。1.8.8 是唯一受支持的 1.8 版本。

问:是否支持 Bukkit?
答:不支持 Craftbukkit。您应该使用 Spigot 或 PaperSpigot。

问:英雄有语言文件吗?你能翻译一下吗
我们没有完整的语言文件,但是您可以自定义和更改描述的部分。请暂时使用MessageFilter 。

问:我可以本地化技能描述吗?
答:是的。您可以通过编辑描述部分在技能.yml 中执行此操作。

问:我可以关闭体力并使用食物系统吗?
答:是的。您可以通过编辑相应的部分在 config.yml 中执行此操作。


有问题/疑问?
  • 在发布错误之前解析您的配置。-在线 YML 解析器
  • 请在 paste2.org 中包含任何错误的服务器版本、英雄版本和技能版本。
  • 在Discord上提问
条款
  • 通过购买此资源,您将获得在您拥有、管理或工作的服务器上使用此插件的权利,只要您与服务器的实际 Minecraft 方面有联系并且只要不违反以下条件.
  • 通过购买此资源,只有您在项目期间拥有支持访问权限。
  • 您不得以任何形式将此插件分发给未获得使用该插件的权利的任何人,例如通过从该资源页面购买该插件。
  • 在已经获得资源后,您无法退款。它应该按照描述工作,如果您有问题,请联系我们,我们将解决它们!打开退款将立即永久撤销您的访问权限。
  • 只要您遵守之前的条款,您就可以修改此插件。
  • 作者可以随时撤销授予您的所有权利,尤其是在违反条款的情况下。
  • 下载即表示您接受之前的条款,并且该资源的分发不由作者提供任何(甚至不是暗示的)保证或责任。
不要在评级中留下错误报告

=================================
最新的 LEGACY 1.12 版本
需要 Vault 1.6 或更低版本
技能需要 6.2 EffectLib ================================ 请粘贴的启动日志和任何相关的错误!包括服务器/英雄版本。 新评论





--- Spigot 需要为http://herocraftonline.com > ( play.hc.to )



创建的 Minecraft RPG 插件 仍然不相信?>>>在此处查看旧版(免费)! &#9829; 享受?给我写一个 ☆☆☆☆☆☆ 评论!超级简单!&#9829;

手机扫码浏览