AsyncWorldEdit - Premium 3.9.4 [提交至百度][查看百度是否已收录此帖]

5241 0
2022-9-24 12:41:25
显示全部楼层
生活圈制作
AsyncWorldEdit - Premium 3.9.4
AsyncWorldEdit - 高级版 3.9.4
付费获得:
下载地址
提取码:1a90
20
您未购买

人民币

免费下载:
打开微信扫一扫下面的小程序二维码
IMG_6393.PNG



测试的 Minecraft 版本:
  • 1.7
  • 1.8
  • 1.9
  • 1.10
  • 1.11
  • 1.12
  • 1.13
  • 1.14
  • 1.15
  • 1.16
  • 1.17
  • 1.18
描述
这个插件只有一个功能:消除WorldEdit造成的卡顿!这是通过连接到 WorldEdit 内部类并用专门准备的类替换其中的一些来完成的。所有 WorldEdit 操作都分为两个阶段:准备和放置块。准备阶段在异步线程中完成并计算需要更改的块列表。第二阶段的所有方块放置都是在包装中完成的。包大小和绘制块的频率可以在配置中配置。AsyncWorldEdit 不是 WorldEdit 的重新实现!它附加了原始 WorldEdit API 和 WorldEdit 类并尝试修复滞后。因此,您可以访问所有 WorldEdit 操作,并且所有这些操作的工作方式与原始 WorldEdit 中的操作完全相同。所以基本上你得到相同的命令,相同的权限和相同的体验。除此之外,如果 WorldEdit 团队发布新功能、修复错误,您只需更新 WorldEdit,AWE 将照常工作。



读这个!在你购买之前。
我无法付款...
一些人报告说他们无法直接从 Spigot 付款。如果您遇到此问题,您可以直接从您的 PayPal 汇款(详情请发邮件给我)。


我为插件付费,但无法下载...
目前所有交易均已接受并手动处理,因此您可能需要长达 24 小时才能访问插件下载。如果交易不是“即时的”(例如:来自银行账户),我会等待交易完成,然后再授予对插件的访问权限。

我给你发了一封电子邮件...我不回复发送到我的 PayPal 电子邮件的电子邮件。在公共论坛上与我联系或给我发送 PM。

我的交易被拒绝了. 我将取消(拒绝)所有符合这些条件的交易:
  • 您使用了未经验证的 PayPal 帐户,
  • 您使用了未注册的 PayPal 帐户,
为什么这么麻烦?插件下载后,我在 PayPal 上收到了退款,而 PayPal 不提供任何级别的针对此类行为的保护。
我手动接受付款,因为有时 PayPal Spigot 连接失败,我需要手动添加用户。


高级版
从 2018 年 1 月 1 日开始,AsyncWorldEdit 高级版和免费版再次成为一个软件。高级版中添加的所有更改和功能现在可供所有人使用。

好的,那么缓存在哪里?首先也是最重要的一点,您不会获得免费版本的支持。基本上你自己。高级版本的所有更新最终将在高级版本发布后添加到免费版本(可能是几天,也可能是几周)。首先,这些更改将作为源代码提供。免费版的 JAR 版本可能会发布,也可能不会。它可能会跳过某些版本,可能与高级版在同一天发布,可能会在几周后发布。源代码将在没有编译说明和 DRM 模块的情况下提供。

那么,当我购买高级版时,我会得到什么?首先,最重要的是,您将获得支持(从简单的故障排除开始到帮助使用源代码)。其次,您不需要自己构建 jar 文件,您将获得一个预构建的 jar 文件。警告:您只能从高级下载页面下载插件的 jar 文件,如果您从其他来源获得它,则它是合法副本(提供 jar 下载会破坏许可证)。

存储库和项目页面

GitHub

我缺少...(我需要...


安装

要安装插件,只需按照以下步骤操作(步骤 5-6 是可选的):
  • 下载并安装WorldEdit 7.1.0
  • 在spigotmc.org上购买插件
  • 下载AsyncWorldEdit.jar
  • 安装AsyncWorldEdit(不再需要注入器)
  • (o) 启用块登录和块访问控制下载BlocksHub
  • (o) 适合您的进度显示插件的桥梁(例如:如果您想使用ActionBarAPI,您需要AsyncWorldEdit-ActionBarAPI
  • (o) 如果您想使用内置的 bos bar,请考虑安装此插件:AsyncWorldEdit - Boss Bar
  • 重启服务器
  • 编辑配置文件
  • 重新启动服务器或执行/AWE reload

从旧版本升级:
如果您是从旧版本的 AWE 升级,在大多数情况下,您不需要做任何特别的事情。虽然如果您使用的旧版本仍然有注射器,您需要将其移除。此外,删除 AWE 桥接插件(位于 /plugins/AsyncWorldEdit/plugins/ 中)和已安装文件是一个很好的做法。

3.6.0 之前
的版本 要安装插件,只需按照以下步骤操作(步骤 5-7 是可选的):
  • 下载并安装WorldEdit 6.1.2(查看发行说明了解确切的版本号)
  • 在spigotmc.org上购买插件
  • 下载AsyncWorldEdit.jar(对于WorldEdit 开发,您需要下载AsyncWorldEdit-dev.jar,您可以在版本历史中找到它。转到版本历史并单击“下载”以获取最新的开发版本)
  • 安装AsyncWorldEdit(注入器会自动安装)
  • (o) 启用块登录和块访问控制下载BlocksHub
  • (o) 如果您使用的PlotMe早于 0.17 并且想要启用 PlotMeFix got to plugins/AsyncWorldEdit/plugins并将AsyncWorldEdit-PlotMe*.jar.dis更改为AsyncWorldEdit-PlotMe*.jar。使用适用于您的 PlotMe 版本的 jar!
  • (o) 如果您想使用其他进度显示插件,请为您的进度显示插件启用适当的桥接器(例如:如果您想使用ActionBarAPI,您需要AsyncWorldEdit-ActionBarAPI
  • 重启服务器
  • 编辑配置文件
  • 重新启动服务器或执行/AWE reload
重要提示:对于 Minecraft 1.12 及更早版本,请使用旧版本 3.5.4 和 WE 6.1.7.3

3.3.0 之前
的版本 要安装插件,只需按照以下步骤操作(步骤 5-7 是可选的):
  • 下载并安装WorldEdit
  • 在spigotmc.org上购买插件
  • 下载AsyncWorldEdit
  • 安装AsyncWorldEdit和AsyncWorldEditInjector
  • (o) 启用块登录和块访问控制下载BlocksHub
  • (o) 如果您使用的PlotMe早于 0.17,并且想要启用 PlotMeFix,请将AsyncWorldEdit-PlotMe*放在您的插件文件夹中。使用适用于您的 PlotMe 版本的 jar!
  • (o) 如果您想使用其他进度显示插件,请为您的进度显示插件放置适当的桥梁(例如:如果您想使用ActionBarAPI,您需要AsyncWorldEdit-ActionBarAPI
  • 重启服务器
  • 编辑配置文件
  • 重新启动服务器或执行/AWE reload
安装 - Forge (Cauldron)
要安装插件,只需按照以下步骤操作:

  • 下载WorldEditWorldEdit Forge
    • 将WorldEdit安装到插件文件夹中
    • 将WorldEdit forge安装到 mods 文件夹中
  • 下载AsyncWorldEdit
    • 将AsyncWorldEditInjector安装到 mods 文件夹中(不要将其放入 plugins 文件夹中!)
    • 将AsyncWorldEdit安装到 plugins 文件夹中(不要将其放入 mods 文件夹中!)
  • 从 p5 开始按照普通版本的安装说明进行操作。
执行安全操作时出错...
AsyncWorldEdit
队列在异步线程中更改块,然后将它们放入包中。由于许多 WorldEdit 操作需要从地图中获取块,AsyncWorldEdit 需要在准备阶段(在异步线程中)获取块。由于几乎不应该从异步线程调用任何 API 调用(它最多有风险)AsyncWorldEdit 检查它是否可以在异步线程中执行块获取。如果它检测到它不可能/不允许,它会将其分派到主线程。有时 AWE 无法检测到不允许操作,这会导致操作失败。AWE 在日志中记录这一事实(执行安全操作时出错)并使用调度程序执行操作。如果使用调度程序处理所有操作,您将体验到速度急剧下降。另一方面,不可能 100% 确定 get 操作不会从异步线程中失败。为了 100% 确定 AWE 需要将自己的类注入 Bukkit 内部工作。


许可证
如需完整许可证,请访问此链接

问题
要报告问题,请使用Github (或此处的高级版)问题跟踪器。

我仍然遇到延迟!
阅读

自动更新
此插件不提供自动更新功能,它只会在有更新时唠叨服务器所有者。要禁用此功能,请在配置中将checkVersion设置为false。或者,如果您不想接收更新信息,您可以删除AWE.admin.version权限节点。

阻止记录器和阻止访问控制
启用 WorldEdit 放置的块的记录,并可以强制块访问。这是使用名为BlocksHub的特殊插件完成的。要启用块日志记录(或块访问控制),您需要在 AWE 配置中启用它。此功能需要您下载、安装和配置BlocksHub,然后安装任何受支持的块记录器(访问控制器)。

新的记录器和新的访问控制插件将直接添加到 BlocksHub 插件中。

警告:要启用 Direct Chunk API 和 BlocksHub 集成,您需要在选项中启用它。

你能走多快?
最近在spigotmc.org上启动了一个线程您可以在其中向其他人展示使用 AsyncWorldEdit 放置块的速度。您还可以使用该线程作为参考,了解如何为您的硬件规范配置 AsyncWorldEdit。
该线程可以在这里找到。

我可以排队多少个街区?
所有测试都是在受控环境中完成的。使用官方的spigot,只安装了AWE和WE ware,服务器上只有1个玩家。AWE 配置未更改。

在最小的服务器(512m)可用内存~200m 上,我设法将最多 1 000 000 个块排队。但是在队列达到 500 000 个块后,由于垃圾收集器,TPS 开始急剧下降。因此,我不建议在具有 200m 空闲内存的服务器上排队超过 500 000 个块。

在一台有 1g 内存、大约 700m 空闲的服务器上,我设法将最多 2500000 个块排队。在队列达到 2 000 000 个块后,由于垃圾收集器,TPS 开始下降。

添加额外的 ram 导致每增加 500m 的空闲 ram,排队块的最大数量增加大约 1500000 个块。当我禁用块冻结功能时,我设法将额外的 20% 块排队,(每增加 500m 的空闲内存,就有 1800000 个块)。

安装 AWE 后插件 X 停止工作
如果安装 AsyncWorldEdit 后插件停止工作,请联系我。我会尽力提供帮助。

使用 AsyncWorldEdit 的插件
如果您是插件作者并且您的插件使用 AWE API,请联系我,我会将您的插件添加到列表中。

API
对于 API 和 Maven,请访问Github。您可能还需要检查:Plugin API

Roadmap
Roadmap


Commands
Commands page

Permissions
Permissions page

Configuration
Configuration page

Changelog
Configuration page

Dependencies
这个插件依赖于:
BlocksHub - 阻止登录并阻止访问
其他可选依赖项:
进度显示插件:
MCStats
这个插件使用 MCStats 来收集统计数据。它只收集为大多数 MCStat 启用的插件收集的标准统计信息(例如:操作系统、Java 版本、CPU、国家、插件和服务器版本)。有关详细信息,请单击下面的图表。要禁用统计信息,您需要禁用 MCStats 的统计信息收集(在 plugins/PluginMetrics/config.yml 中将 opt-out 设置为 true)。这将禁用所有使用默认 MCStats 的插件的所有统计信息收集。

感谢您使用此插件。

没有服务器...
试用 BisectHosting 并通过代码获得 25% 的折扣 SBPrime项目人员 项目作者/开发人员: SBPrime前开发人员: EDawg878前测试人员:







RulingKyle1496, Lukeer31, PsychoNavigat
前维基作者: Phudster,Magic

Donate
程序员:
“一种将咖啡因和披萨变成软件的有机体”。

如果你喜欢你可以给我买一个披萨


如果你喜欢我的作品,你可以购买插件的高级版本。


手机扫码浏览